Buffalo Nas not detected.

HOME Forums Tech PC Talk Buffalo Nas not detected.

This topic contains 11 replies, has 5 voices, and was last updated by Ed P 2 weeks ago.

  • Creator
    Topic
  • #29653

    keith with the teef
    Participant
    @thinktank

    A up lads, decided to bring my nas up to date, firmware 1.74 w10. Buffalo sl chl rebooted and said all was good but windows cannot detect nas drive.

    looks like? all adresses to detection have been wiped?

    I’m a bit lost here!

Spread the love
Viewing 11 replies - 1 through 11 (of 11 total)
  • Author
    Replies
  • #29654

    Dave Rice
    Moderator
    @ricedg
    Forumite Points: 1,584

    There is a Windows update that’s been knackering network access, it’s fixed by upgrading to the latest version of W10 – 1809.

    You can probably still access it via it’s IP address \\ipaddress\sharename

    0
    0
    #29656

    Tippon
    Keymaster
    @tippon
    Forumite Points: 1,291

    You might find that it’s because of SMB1 being removed from Windows 10. I’ve got a Buffalo LinkStation that won’t connect to Windows anymore because of it. Ubuntu 18.04 connects to it with no problem though.

    I can understand why MS removed it, but the sudden lack of access to my backup device with no explanation really wasn’t helpful.

    0
    0
    #29658

    Richard
    Participant
    @sawboman
    Forumite Points: 1,650

    The withdrawal of the SMB1 function has been heralded for so long even the wide boys thought it should just go, I disabled it months ago, could even be more than a year ago. I agree with Dave 1809 did greatly improve finding devices on my network allowing the server, several print servers and the PVRs to be seen and usually used from my PC. An old Buffalo device is hung off of the USB port on one of my repurposed old routers that now acts as an AP and that Buffalo can be seen and accessed very easily.

    • This reply was modified 2 weeks, 3 days ago by Richard.
    0
    0
    #29667

    Dave Rice
    Moderator
    @ricedg
    Forumite Points: 1,584

    1.74 was actually released in Feb 18 and it fixes Samba ver 3+ vulnerabilities, so I don’t think it’s an SM1 issue. The previous update was July 17, again Samba vulnerabilities. You have to go back to 2013 for any o/s bug fixes.

    0
    0
    #29668

    keith with the teef
    Participant
    @thinktank
    Forumite Points: 360

    TY for replies.

    OK It is done. I used Fing io to find the linkstation which gave me the IP address. I then went into it and set to share. Whooooo! Now watching Ice Cold In Alex and I’m Having A Beer 2 🙂

    0
    0
    #29674

    Tippon
    Keymaster
    @tippon
    Forumite Points: 1,291

    The withdrawal of the SMB1 function has been heralded for so long even the wide boys thought it should just go, I disabled it months ago, could even be more than a year ago.

    That’s one of the reasons it threw me. I remember the fuss, and the updates that supposedly turned it all off, and my NAS worked afterwards. Like most people, I had no clue what the Buffalo box was running, just that it was up to date according to the web interface. A few weeks ago I tried to double check a backup before I went away, and I couldn’t access it through Windows.

    God knows why, but Windows let me access it up until recently.

    0
    0
    #29676

    Dave Rice
    Moderator
    @ricedg
    Forumite Points: 1,584

    It’s the Windows update before the big 1809. I’ll try and find the KB number.

    0
    0
    #29681

    Tippon
    Keymaster
    @tippon
    Forumite Points: 1,291

    Thanks Dave, but don’t worry. I’m not going to risk rolling it back, especially if Ubuntu can access the drive. I’ve got it running in VirtualBox, so I can get the files off if I need to. It doesn’t look like Buffalo are going to release an update to help out either, so I’ll just retire the boxes.

    0
    0
    #29686

    Dave Rice
    Moderator
    @ricedg
    Forumite Points: 1,584

    When your W10 boxes upgrade to 1809 (you can force it with Update Assistant) they’ll be back again.

    0
    0
    #29697

    Tippon
    Keymaster
    @tippon
    Forumite Points: 1,291

    I’ll have to check tomorrow  but I’m pretty sure that they’re on 1809.

    I think Windows just doesn’t like me 😀

    0
    0
    #29725

    Ed P
    Participant
    @edps
    Forumite Points: 2,482

    Have you fixed it yet – you could try a hack to add smb2 (of course the usual backup important files applies!) — link

    Meantime for use my linkstation now i have modified /etc/init.d/smb.sh
    after this line –> /usr/local/sbin/nas_configgen -c samba
    add this line –> sed -i ‘2 i\ max protocol = SMB2’ /etc/samba/smb.conf

    after restart linkstation, my window pc with SMBv1 disabled, can work with the NAS.

    For the usual reasons I would not advise hacking Windows to allow smb1

    0
    0
Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Spread the love