CPUZ shows my ram is running at 1333Mhz and not 1600Mhz

HOME Forums Tech PC Talk CPUZ shows my ram is running at 1333Mhz and not 1600Mhz

This topic contains 5 replies, has 4 voices, and was last updated by Wheels-Of-Fire 6 days, 6 hours ago.

  • Creator
    Topic
  • #28893

    rockonbazza
    Participant
    @rockonbazza

    Hi. I have DDR3 1600Mhz ram in my PC. CPUZ shows my DRAM Frequency is 669.6Mhz , and I just found out that means my ram is running at 1333Mhz, not 1600Mhz. I have read that I should check my BIOS and enable XMP. However, on checking my BIOS, it states XMP is enabled – Profile 1.

    My bios memory settings area showing as follows –

    XMP – Profile 1

    System memory multiplier = = = 8.00 – Auto

    Memory Mhz = = = 1334Mhz – 1600Mhz

    The only options available with XMP are Disabled, or Profile 1. I cant remember exactly but on “system memory multiplier” I clicked on “auto” and it gave the options – Auto, Quick, and Expert.

    Until recently I had 2 x 4gb sticks of ram, dual channel, and I added another 2 x 4gb sticks recently – 16GB in total. However CPUZ showed the same DRAM Frequency prior to me adding more ram. The line memory Mhz confuses me as it states 1334Mhz and next column along 1600Mhz.

    My timings for both channels show 9 9 9 24. Voltage is 1.5. I couldnt see any option to change System Memory Multiplier which is currently listed as 8.00 Auto.

    Am I running at 1600Mhz – if not how do i change the bios to get it to 1600Mhz. Or if I am running at 1333Mhz, would I notice any difference changing to 1600Mhz ? My mobo is a Gigabyte GA-970-DS3P. I mainly use my PC for gaming. Any suggestions would be much appreciated. Thanks.

Spread the love
Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #28896

    Dave Rice
    Moderator
    @ricedg
    Forumite Points: 1,454

    Don’t worry about it, you won’t notice any difference.

    0
    0
    #28897

    rockonbazza
    Participant
    @rockonbazza
    Forumite Points: 34

    😀 LOL. Thanks Dave. Quick reply, short and straight to the point – and I am no longer worrying about it. Thanks

    0
    0
    #28899

    Wheels-Of-Fire
    Participant
    @grahamdearsley
    Forumite Points: 886

    Dont worry but just in case..

    Your memory speed is:

    System base clock x memory multiplier x 2 because its Double Data Rate.

    If you do the maths then it looks your base clock is 83.7 so if you changed the multiplier to x10 your memory would be running at 1674. Thats higher than your memory’s rated 1600 a could be why AUTO chose an 8x multiplier.

    If you want to try x10 then you probably need to change your multiplier setting to EXPERT first and you may need to disable XMP too.

    But as Dave said…

    0
    0
    #28902

    Ed P
    Participant
    @edps
    Forumite Points: 2,285

    It can also be controlled by ‘Green’ settings.

    Tbh as Dave says it is virtually unnoticeable unless you are ploughing through a huge database or doing some cutting edge rendering. The price of leccy has driven me to normally using ‘Green’ settings and only ramping up the CPU on the rare times I need to run three or more vms simultaneously.

    0
    0
    #28917

    Wheels-Of-Fire
    Participant
    @grahamdearsley
    Forumite Points: 886

    In case you were wondering why it makes so little difference now, then its because modern CPU’s have 3 levels of full speed cache memory. The CPU only has to wait for main memory in the event of the data not being in the chache, and its less than 1% of the time these days.

    0
    0
Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Spread the love