Forumite

Intel NUC wont update drivers

HOME Forums Tech Windows Talk Intel NUC wont update drivers

This topic contains 3 replies, has 2 voices, and was last updated by Drezha 4 months, 1 week ago.

  • Creator
    Topic
  • #35475

    Drezha
    Participant
    @drezha

    So I’d installed Windows 10 on my NUC a while ago, and I’ve got round to ensuring that the drivers are up to date, as I’d noticed that Youtube was laggy (previously it was used at cadets, so for maybe two hours at a time and was only used for office stuff).

    I’ve downloaded the Intel driver management stuff, and gone through it – but basically it won’t install the graphics drivers. I’ve currently got Windows Update running which I’ll hope will sort the issue, but trying to install the Intel drivers direct from Intel gives me a warning

    This happens if I download direct from Intel as well – even older drivers. So at the minute, it’s saying I’m using Microsoft Basic Display Adapter.

    Might end up having to put Linux on it at this rate, as that was the initial OS it was using when I had it and that worked perfectly!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #35476

    Dave Rice
    Moderator
    @ricedg
    Forumite Points: 4,209

    Found this:

    Starting with Windows 10, version 1607 (Build 14310 and later), the format adds a new part in the INF file: the [BuildNumber] part. That means that it started to define the build number of the Windows version when installing the drivers. Soon after, Intel has started to adopt this new technique and also add the [BuildNumber] part into the installation information.

    That is to say, If the build number of your Windows version doesn’t fit with the defined [BuildNumber] part of the package by the driver manufacturers, you will fail to install the driver package, despite the correct Windows version and processor type.

    0
    0
    #35478

    Drezha
    Participant
    @drezha
    Forumite Points: 1,692

    Ok, I should be fine once the latest update is complete then, as the download I have states 16225 and systeminfo states 15063, so I’m hoping this will work!

    0
    0
    #35479

    Drezha
    Participant
    @drezha
    Forumite Points: 1,692

    That did the trick!

    Cheers for the article. I’d found something similar last night but required manually browsing the to the INF file etc and didn’t work anyhow 🙁

    All sorted now mind.

    0
    0
Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Thank you for visiting Forumite. If you appreciate the site please consider a donation to show your appreciation.
Take Me There!