Tech Linux Talk Pesky 169.254.x.x

This topic contains 1 reply, has 1 voice, and was last updated by Ed P 4 months, 3 weeks ago. This post has been viewed 185 times

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #12119

    Ed P
    Participant
    • Total Posts 1363
    • Offline
    • @edps
      Forumite Coins: 270

    When your wireless interface gets stuck negotiating a DHCP handshake with your wireless router there are times when the nuclear option of the shutdown buttons for everything does not work! You will know when it happens as ifconfig (or ipconfig for windows) keeps returning the pesky 169.254.x.x address meaning that the DHCP handshake has failed.

    After half a day pfaffing around with a Raspberry Pi Zero (no wired option) I found a solution:  try:

    sudo dhclient -r wlan0
    sudo dhclient wlan0

    I have no idea why this problem started other than it coincided with an update – bah!

    for some unknown reason the above worked while

    sudo ifdown wlan0

    sudo ifup wlan0

    failed???

    • This topic was modified 4 months, 3 weeks ago by Ed P.
    #12134

    Ed P
    Participant
    • Total Posts 1363
    • Offline
    • @edps
      Forumite Coins: 270

    Edit, I think I identified a solution, and possible cause. The solution was to dial down my Hub to the ‘legacy’ setting. As things used to work just fine with the b/n/g setting it suggests either the Pi suffered a wifi driver regression or BT have regressed their driver in some way. The problem was evidenced as a dhcp link that kept dropping out.

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Members Currently Active: 2
JayCeeDee, Sawboman
Keymaster | Moderator | Participant | Spectator | Blocked
Additional Forum Statistics
Threads: 983, Posts: 12,318, Members: 136
Welcome to our newest member, neucarepamphgesp
Most users ever online was 11 on June 5, 2017 1:36 pm