Program Closing Down

HOME Forums Tech Linux Talk Program Closing Down

This topic contains 5 replies, has 2 voices, and was last updated by Drezha 5 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #14366

    Drezha
    Participant
    @drezha
    Forumite Coins: 238

    I’ve a couple of programs that keep closing down on my Pi and I can’t figure out why. The Pi isn’t restarting, as the uptime is showing that it’s remaining on. But I can’t put my finger on what’s happening.

    For example, one of the programs is screen – it remains on for a period of time but the next time I go to access the Pi via SSH, it’s not working, which sort of defeats the point of using it!

    Any ideas on what I can check?

    #14373

    Ed P
    Participant
    @edps
    Forumite Coins: 936

    Damn – just lost my much longer response by navigating away!

    Try the following:

    Disable the extremely stupid default screen blanking. see Pi Forum.  The only cure that worked for me was the one given in the last response to install and disable xscreensaver!

    Eliminate overheating by adding heat sinks and fans.

    If your program has a lot of i/o use a usb boot with a metal encased usb stick. I had to superglue a heat sink to this as the stick was running painfully hot.

    #14376

    Drezha
    Participant
    @drezha
    Forumite Coins: 238

    I thought I was running in a headless mode for a server only and no X server, but I’ll check in to that over the weekend. I only access it via SSH anyhow.

    Resilo Sync is running on it with storage to a USB and that’s working fine.

    If it was overheating, surely it would effect all processes rather than close the offending program?

    #14381

    Ed P
    Participant
    @edps
    Forumite Coins: 936

    I thought I was running in a headless mode for a server only and no X server, but I’ll check in to that over the weekend. I only access it via SSH anyhow. Resilo Sync is running on it with storage to a USB and that’s working fine. If it was overheating, surely it would effect all processes rather than close the offending program?

    You are probably correct unless the overheating is in the read/write area, that is why I threw in the comment about a metal encased usb stick for booting. If you are using an SSD forget my comment.

    When you say ‘close’ is it ‘close’ or unresponsive/locked. You can check its status if not locked using ‘top’. If it is not locked then I suspect it is the stupid screen blanker. If you are running vnc or the like the gui is there whether you want it or not. If you are just in ssh I do not know but I still suspect the stupid ‘blanker’ as it seems to cut out all comms. Suck it and see by trying the xscreensaver fix (I think ‘x’ has to be running even in headless mode as it is core to many kernel i/o processes)

    • This reply was modified 5 months, 1 week ago by Ed P.
    #14420

    Drezha
    Participant
    @drezha
    Forumite Coins: 238

    The process in question is writing to the microSD I imagine, so it could be that.

    I’ve disabled VNC in the Raspi-Config. I’d already got it set to boot to direct to terminal. I’ll try it with VNC disabled, otherwise, I’ll go down the screen saver route.

    #14423

    Drezha
    Participant
    @drezha
    Forumite Coins: 238

    Missed the edit window, but it seems that might have been it. Disabled VNC as described above and that seems to have solved it. I’ll keep an eye on it, but looks like it might be sorted now.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.