Some help please

HOME Forums Tech PC Talk Some help please

This topic contains 4 replies, has 2 voices, and was last updated by isdarit 2 months, 1 week ago.

  • Creator
    Topic
  • #31619

    isdarit
    Participant
    @isdarit

    My lad has bought himself a new setup including a case . ( case a bit gimmicky if you ask me but he payed about £100 for it so maybe not) anyhow  when we switch it on nothing happens no fans  the mobo lights up but nothing else. I’m convinced it’s the power switch on the case. Thinking about jumping it but just wondering if anyone had any ideas first? Thanks guys . John

Spread the love
Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #31621

    PlaneMan
    Moderator
    @planeman
    Forumite Points: 1,916

    Dumb question but all the connections have been checked?

    The extra power to the mobo from the PSU in particular, if it needs it.

    My Instagram

    My YouTube

    0
    0
    #31623

    isdarit
    Participant
    @isdarit
    Forumite Points: 148

    Thanks for reply Planeman he has taken all apart I’m going to build it up with him  in a bit .

    0
    0
    #31626

    PlaneMan
    Moderator
    @planeman
    Forumite Points: 1,916

    Smart move

    My Instagram

    My YouTube

    0
    0
    #31679

    isdarit
    Participant
    @isdarit
    Forumite Points: 148

    Sorted it planeman thanks. After he said I wouldn’t be able to sort because I’m old (51) And haven’t a clue. Yeh sound son that mobo doesn’t support that cpu😉. I would of let you know earlier but I’ve been busy sitting here all smug🤣👍. Thanks for your input mate

    2
    0
Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Spread the love